粉刷匠知识分享网

k线的箱体指标公式

求助把通达信箱体指标做成一个选股公式

箱底:=TROUGH(3,5,1)*0.999;
GL:BETWEEN((C-箱底)/箱底*100,0,1);
友情提示:箱体指标本来用了未来函数画线;因此这个选股公式必然也要用到未来函数,谨慎使用。

如何把这个通达信箱体指标做成选股公式?

可以编写箱体指标选股公式,收盘价大于箱顶,但这个条件又可能连续成立,是只要大于就可以呢,还是选择首次大于箱顶呢.

箱体调整选股公式

a1:=abs((c-ref(c,1))/ref(c,1))<=0.05
and abs((o-ref(c,1))/ref(c,1))<=0.05
and c>=ref(c,1) and l<=ref(h,1);
a2:=ref(c,1)>ref(o,1) and (ref(c,1)/ref(o,1))>=4.95/100
and ref(c,1)/ref(c,2)>=1.04 and ref(c,1)>ref(c,2)
and ref(c,1)>ref(c,3) and ref(c,1)>ref(c,4)
and ref(c,1)>ref(c,5) and ref(c,1)>ref(c,6)
and ref(c,1)>ref(c,7) and ref(c,1)>ref(c,8)
and ref(c,1)>ref(c,9);
a3:=if(a1 and a2,3,0);
a4:=barslast(a1 and a2);
a8:=ref(c,a4+1);
a5:=abs((c-ref(c,1))/ref(c,1))<=0.03
and abs((o-ref(c,1))/ref(c,1))<=0.03;
a6:=(c>=a8 and c/a8<=(4/100));
BACKSET(a4=count(a5 and a6,a4),1);

求股票主图指标 布林线和箱体叠加的指标公式

平衡:EMA(C,20),CIRCLEDOT,COLORWHITE;
上轨:平衡 + 2*STD(C,20),LINETHICK2,COLORFF00FF;
下轨:平衡 - 2*STD(C,20),LINETHICK2,COLOR00FF00;
Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9),3),1);
DRAWTEXT(CROSS(CLOSE,Y1),LOW,'[买进]'),COLORYELLOW;
DRAWTEXT(CROSS(Y1,CLOSE),HIGH*1.05,'[卖出]'),COLORWHITE;
VAR1W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3W:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWTEXT(CROSS(VAR2W,MA(VAR3W,6)),LOW -0.6,'(买)'),COLORFF99FF;
DRAWTEXT(CROSS(MA(VAR3W,6),VAR1W),HIGH +0.9,'(卖)'),COLORCCFF13;
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR3P>90,LOW*0.92,'追涨'),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1)),COLORYELLOW;
DRAWTEXT(买,L*0.95, '必涨'),COLORRED;
多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
DRAWTEXT(CROSS(78.89,多方),H+1.5,'(逃顶)'),COLOR00FF00;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;
A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1,EMA(A1,5))AND EMA(A1,5)<A5,L*0.98,'(黑马)'),COLORYELLOW;
VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;
VAR2:=SMA(VAR1,3,1)*100;
趋势线:=SMA((SMA(VAR2,3,1)*VAR1),3,1)*1;
VAR9:=CROSS(趋势线,(SMA(VAR2,3,1)*VAR1)) AND (SMA(VAR2,3,1)*VAR1)>8;
DRAWTEXT(VAR9 AND COUNT(VAR9,1)=1,H+0.6,'逃'), LINETHICK2,COLORYELLOW;

通达信趋势+五日箱体+带状操盘线主图指标公式怎么用

要看到源码才知道!

求通达信股票主图指标公式,定重谢:追加悬赏

看起来不过就是个简单的双均线指标,只是加了个穿越后改用不同颜色的圆点显示而已啊。
你再叠加个普通的均线指标,然后把参数设置成一样,看看是否两个图形重合就知道了。